Microsoft+CrowdStrike Global IT Outage lingering impact
Incident Report for DPS AdTracker
Resolved
Microsoft has updated all the status pages except for Virtual Machines (VMs) that they have resolved issues and customers should see relief. Please continue to monitor Microsoft's pages for further details.

Azure: https://azure.status.microsoft/en-us/status/

Office 365: https://status.cloud.microsoft

Xbox Live: https://support.xbox.com/en-US/xbox-live-status
Posted Jul 19, 2024 - 11:55 EDT
Monitoring
Since the initial reporting, this problem has widened significantly. This is not something that DPS controls in any way -- it is extenral to DPS and is a large global issue that has impacted emergency services, airlines, banks, governments, etc.

Microsoft now states that "Users may notice that some of the affected users are seeing relief as we continue to mitigate the impact."

Impacted services may include but are not limited to the following:
- PowerBI: Users may notice that their service is in read-only mode while we address impact.
- Microsoft Fabric: Users may notice that their service is in read-only mode while we address impact.
- Microsoft Teams: Users may be unable to leverage Microsoft Teams functions including presence, group chats, and user registration.
- Microsoft 365 admin center: Admins may be intermittently unable to access the Microsoft 365 admin center and any action may be delayed if accessible.

Microsoft believes that the following services are recovered or recovering:
- Microsoft Defender
- Microsoft Defender for Endpoint
- Microsoft Defender Experts
- Microsoft Intune
- Microsoft OneNote
- OneDrive for Business
- SharePoint Online
- Windows 365
- Viva Engage
- Microsoft Purview


What happened?

Microsoft (among other companies) continues to suffer from a global outage that has affected its services including Office 365, Azure, and Xbox Live. It has been confirmed that the issue is due to a faulty update from a firm used by other companies as well -- CrowdStrike. The faulty update from CrowdStrike caused the "Blue Screen of Death" (BSOD) or more generally Microsoft services to crash. Both CrowdStrike and Microsoft are working to resolve the issue. The outage has affected users worldwide and has caused a lot of frustration for those who rely on Microsoft services for work and personal use. Some users are completely unable to work, while others are able to work unaffected.

Microsoft stated this on the Azure Support Twitter/X Account (https://x.com/AzureSupport/status/1814226224937402684) earlier this morning:
"We experienced a Storage incident in Central US which had downstream impact to a number of Azure services. This is currently mitigated, however we are still in the process of validating recovery to a small percentage of those downstream services. This was communicated to affected customers via the Service Health dashboard in the Azure portal. We are also aware of an issue impacting Virtual Machines running Windows, running the CrowdStrike Falcon agent, which may encounter a bug check (BSOD) and get stuck in a restarting state. While this is an external dependency, we are currently investigating potential options for Azure customers to mitigate and will be providing updates via the status page here: https://azure.status.microsoft/en-us/status/ as well as our Azure portal, where possible."

Microsoft has also stated that service recovery began around 4:30AM and services should start coming right within the next few hours.


You may use these links to monitor the various issues directly from Microsoft:

Azure: https://azure.status.microsoft/en-us/status/

Office 365: https://status.cloud.microsoft

Xbox Live: https://support.xbox.com/en-US/xbox-live-status


For deeper understanding, here are some news articles from reputable sources:

USAToday: https://www.usatoday.com/story/money/2024/07/19/global-outage-communications-systems/74465953007/

c|net: https://www.cnet.com/tech/services-and-software/microsoft-global-outage-explained-911-lines-down-flights-grounded-and-more/

Windows Central: https://www.windowscentral.com/microsoft/mitigation-actions-microsoft-cloudstrike-outages

MSPowerUser: https://mspoweruser.com/is-microsoft-down-heres-what-you-need-to-know-about-recent-crowdstrike-fiasco/



We will continue to monitor the situation, however, this is outside our control and is a global impact issue.
Posted Jul 19, 2024 - 09:19 EDT
This incident affected: Microsoft Azure + Office Cloud Services (Microsoft Teams + Phone System, Microsoft Office 365 Services).