All of our issues are no longer reporting problems. We're going to cease monitoring this.
Update from Microsoft: "We have completed deployment of our ‘last known good’ configuration, and recovery is progressing steadily. We are currently recovering nodes and re-routing traffic through healthy nodes across the global fleet. As recovery continues, some requests may still land on unhealthy nodes, resulting in intermittent failures or reduced availability for a subset of customers.
This recovery effort involves reloading configurations and rebalancing traffic across a large number of nodes to restore full operational scale. The process is gradual by design, ensuring stability and preventing overload as dependent services recover.
The AFD service is now operating above 98% availability. While the majority of customers and services are mitigated or seeing strong improvement across affected regions, we are continuing to work on tail-end recovery for remaining impacted customers and services. We have revised our mitigation time and are currently tracking toward full mitigation by 00:40 UTC on 30 October 2025, though we will communicate if mitigation is achieved sooner."
Posted Oct 29, 2025 - 20:11 EDT
Update
At this time, the majority of services are operational. We will leave this issue open to track it in case.
From Microsoft: "We initiated the deployment of our ‘last known good’ configuration, which has now successfully been completed. Customers may have begun to see initial signs of recovery. We are currently recovering nodes and routing traffic through healthy nodes, and as we make progress in this workstream, customers will continue to see improvement.
...
At this stage, we anticipate full mitigation within the next four hours as we continue to recover nodes. This means we expect recovery to happen by 7:20 US/EDT on 29 October 2025.."
Posted Oct 29, 2025 - 16:22 EDT
Monitoring
An update from Microsoft: "We have pushed our ‘last known good’ configuration, and customers may begin to see initial signs of recovery. We are currently recovering nodes and routing traffic through healthy nodes, and as we make progress in this workstream, customers will continue to see improvement.
Customer configuration changes will remain temporarily blocked while we continue mitigation efforts. We will notify customers once this block has been lifted.
Some customers may also have experienced issues accessing the Azure management portal. We have failed the portal away from AFD to mitigate these access issues. Customers should now be able to access the Azure portal directly, and while most portal extensions are functioning as expected, a small number of endpoints (e.g., Marketplace) may still experience intermittent loading problems.
We are continuing to monitor progress closely and will provide an ETA for full mitigation within the next 20 minutes as we assess recovery across the AFD service."
Posted Oct 29, 2025 - 15:04 EDT
Identified
Since approximately 12:00PM US/EDT, some customers in certain locations began experiencing sporadic issues reaching Azure hosted websites, Azure Windows Virtual Desktop (WVD), Office 365 resources, and Microsoft 365 Portals.
This does not appear to be impacting all customers in every location. If you are experiencing this, Microsoft is currently working on remediation.
Their latest update states: "Users may be unable to access the Microsoft 365 admin center and see delays when accessing other Microsoft 365 services. Customers and Microsoft services leveraging Azure Front Door (AFD) may have experienced latencies, timeouts, and errors.
Current status:
We have initiated the deployment of our last known good configuration, which is expected to complete within 30 minutes. As this deployment progresses, customers should begin to see initial signs of recovery. Once completed, we will begin recovering nodes and routing traffic through these healthy nodes.
Customer configuration changes will remain temporarily blocked while we continue mitigation efforts. We will notify customers once this block has been lifted.
Some customers may also have experienced issues accessing the Azure management portal. We have failed the portal away from AFD to mitigate these access issues. Customers should now be able to access the Azure portal directly, and while most portal extensions are functioning as expected, a small number of endpoints (e.g., Marketplace) may still experience intermittent loading problems.
We do not yet have an ETA for full mitigation, but we will provide another update within 30 minutes, once the deployment has completed."
This incident affected: Microsoft Azure + Office Cloud Services (Microsoft Teams + Phone System, Windows Virtual Desktop (WVD), Azure - North Central US (Chicago) Region, Azure - South Central US (San Antonio) Region, Azure - East Central (Virginia) Region, Azure - New Zealand (Auckland) Region, Azure - West India (Mumbai) Region, Microsoft Office 365 Services, Microsoft Copilot, Azure OpenAI Services).