Adobe has changed their advisement on this issue to be of a substantially reduced scope: "Some users may experience issues when downloading Neural Filters in Photoshop."
Since this is now limited to certain filters, we are going to cease monitoring the issue directly.
If you would like further updates, you may follow this issue directly from Adobe by visiting https://status.adobe.com and subscribing to Issue #202504010031.
Posted Apr 01, 2025 - 14:06 EDT
Identified
This following issue is not within the control of DPS. This is using your company's third party contract with Adobe Creative Cloud where they are having an issue. We are sharing this, as users are experiencing frustration with Photoshop.
Adobe has opened Issue #202504010031 where users of Adobe Creative Cloud are experiencing problems with Photoshop Desktop. This impacts our customers using versions 2019 and later. It does not impact CS6.
This is the exact detail Adobe has on their site: Today 11:35 AM (EDT) Impact severity: Major Impact scope: Some customers are impacted. Services impacted: Photoshop Desktop Impact description: We’re investigating an availability issue.
You may follow this issue directly by visiting https://status.adobe.com and subscribing to Issue #202504010031.
Posted Apr 01, 2025 - 11:48 EDT
This incident affected: Adobe Creative Cloud (Login, Licensing, Cloud Services).